मैं अपने आरओआर ऐप को अपडेट करने की कोशिश कर रहा हूं जो वर्तमान में रूबी 1.9.3 और रेल 4.2.4 है

मैं रूबी 2.2.2 और रेल 4.2.4 में जाने की कोशिश कर रहा हूं, जो कि मोंगोडीबी 3.2 चलाने के लिए न्यूनतम है।

जब मैंने अपनी जेमफाइल को रूबी 2.2.2 में बदल दिया और bundle install, और bundle update चलाया, तो मुझे रेल (~> 4.2.4) 4.2.10 पर हल हो गई

जब मैं अपने जेमफाइल में रेल (~> 4.2.4) पर सेट करता हूं तो यह इसे 4.2.10 पर क्यों हल कर रहा है?

नीचे जेमफाइल।

source 'https://rubygems.org'
ruby '2.2.2'
gem 'rails', '~> 4.2.4'
gem 'mongo', '~> 2.1.1'
gem 'bson_ext', '~> 1.12.1'
gem 'mongoid', '~> 5.0.0'
# mongoid seemed to want these to run the generator
gem 'execjs', '~> 2.6.0'
gem 'therubyracer', '~> 0.12.2'
gem 'devise', '~> 3.5.2'
gem 'grape', '~> 0.13.0'
#gem 'grape-swagger'
gem 'thin', '~> 1.6.4'
gem 'geocoder', '~> 1.2.11'
#gem 'mongoid_geospatial'
gem 'kaminari', '~>1.0.0' # pagination
#gem 'iron_worker_ng', '~> 1.6.6'
gem 'iron_worker', '~> 3.1.0'
gem 'newrelic_rpm', '~> 3.13.2.302'
gem 'newrelic-grape', '~> 2.0.0'
#gem "opentok"
gem 'mandrill-api', '~> 1.0.53'
gem 'aws-sdk', "~> 1"
gem 'nexmo', '~> 3.0.0'
gem 'rmagick', '~> 2.15.4', :ref => '69db6635c2630ffd63c1858646cbc280226f31a7bc34e1c9d1322c2c73e1e386'
#gem 'stripe', :git => 'https://github.com/stripe/stripe-ruby', :ref =>'df2e36287d88726c6a03ec6c1fdc19b5d6e2b274'
gem 'stripe', '~> 1.22.0'
gem 'gibberish', "~> 2.0.0"
#gem 'mongoid-encrypted-fields', :path => "./vendor/plugins/mongoid-encrypted-fields-1.2.2"
gem 'twilio-ruby', '~> 4.4.0'
gem 'gcm', '~> 0.1.0'
gem 'chronic', '~> 0.10.2'
gem 'oauth2', '~> 1.1.0'# for stripe connect
gem 'aescrypt', '~> 1.0.0'
gem 'houston', '~> 2.2.3'
gem 'hashids', '~> 1.0.3'
gem 'rack-cors', '~> 0.4.0', :require => 'rack/cors'
gem 'mail', '~> 2.6.4'
gem 'sendgrid-ruby', '~> 1.1.6'

group :production, :staging do
    gem 'rails_12factor', '~> 0.0.3'
end

group :development, :test do
  gem 'factory_girl_rails', '~> 4.6.0'
  gem 'timecop', '~> 0.8.0'
  gem 'debugger', '~> 1.6.8'
  gem 'typhoeus', '~> 0.8.0'
end

# Gems used only for assets and not required
# in production environments by default.
#group :assets do
#  gem 'sass-rails'
#  gem 'coffee-rails'

  # See https://github.com/sstephenson/execjs#readme for more supported runtimes
  # gem 'therubyracer', :platforms => :ruby

#  gem 'uglifier'
#end
gem 'uglifier', '~> 2.7.2'
gem 'jquery-rails', '~> 4.0.5'
0
jdog 26 नवम्बर 2018, 08:26

1 उत्तर

सबसे बढ़िया उत्तर

स्क्विगली एरो ~> सिंबल का मतलब है कि आखिरी माइनर वर्जन को लेटेस्ट वर्जन में अपडेट किया जाएगा। तो 4.2.4 का समाधान 4.2.X कर दिया जाएगा जहां X नवीनतम उपलब्ध है।

यदि आप 4.2.4 से चिपके रहना चाहते हैं, तो = जैसे gem 'rails', '= 4.2.4' का उपयोग करें।

3
max 26 नवम्बर 2018, 06:00