मेरे पास एक लाइव SQL सर्वर डेटाबेस है जो मूल रूप से एक एक्सप्रेस संस्करण पर था और इसकी संगतता 100 है। मैं SSMS 2016 RC का उपयोग करके इसका निरीक्षण कर रहा हूं, जो कि 120 का उच्चतम संगतता स्तर लगता है।

कार्य करने पर Deploy Database to Microsoft Azure SQL Database... यह सत्यापन के सभी चरणों से गुजरता है और फिर त्रुटि के साथ बाहर निकलता है:

पैकेज आयात नहीं कर सका। मास्टर या लक्ष्य सर्वर X से कनेक्ट करने में असमर्थ। आपके पास मास्टर या लक्ष्य सर्वर X . में समान पासवर्ड वाला उपयोगकर्ता होना चाहिए

क्या डेटाबेस के संगतता संस्करण को अपग्रेड करने का एकमात्र समाधान है और क्या यह इतने पुराने स्तर से भी संभव है? क्या मुझे ऐसा करने के लिए एक नया SSMS स्थापित करना होगा?

मैंने नीचे एक समान प्रश्न देखा है, लेकिन यह एसएसडीटी को संदर्भित करता है, एसएसएमएस को नहीं: SSDT प्रकाशित करने में विफल: " करने में असमर्थ मास्टर या लक्ष्य सर्वर से कनेक्ट करें"

0
Savage 31 मार्च 2020, 20:12

1 उत्तर

सबसे बढ़िया उत्तर

मैंने नवीनतम SSMS v18.3 स्थापित किया और फिर से परिनियोजन ऑपरेशन किया और यह बिना किसी रोक-टोक के चला गया, यहाँ तक कि मुझे संगतता स्तर को बदलने की आवश्यकता के बिना भी

0
Savage 1 अप्रैल 2020, 14:29