हाल ही में मैंने अपने कोणीय एप्लिकेशन को कुछ अलग फ़ोल्डर में ले जाया। तब से जब मैं ऐप बनाना चाहता हूं तो मुझे यह त्रुटि मिलती है:

स्कीमा सत्यापन निम्नलिखित त्रुटियों के साथ विफल हुआ: डेटा पथ "" में आवश्यक संपत्ति 'tsConfig' होनी चाहिए

मैंने जिथब और स्टैक ओवरफ्लो में देखने की कोशिश की और केवल ये लिंक पाए:

https://github.com/angular/angular-cli/issues/11479

वे कहते हैं कि मुझे एक पैकेज डाउनग्रेड करना है:

"@ कोणीय-देवकिट/बिल्ड-कोणीय": "^0.800.1" से "^0.12.4"

लेकिन यह सही तरीका नहीं लगता

{
  "name": "@xxx/ma",
  "version": "1.1.0",
  "private": true,
  "license": "UNLICENSED",
  "scripts": {
    "ng": "ng",
    "start": "ng serve --proxy-config proxy.conf.js",
    "build": "ng build --prod",
    "test": "ng test",
    "lint": "ng lint",
    "e2e": "ng e2e",
    "doc": "compodoc -p src/tsconfig.app.json -s"
  },
  "dependencies": {
    "@angular/animations": "~8.2.1",
    "@angular/cdk": "~8.2.1",
    "@angular/common": "~8.2.1",
    "@angular/compiler": "~8.2.1",
    "@angular/core": "~8.2.1",
    "@angular/flex-layout": "8.0.0-beta.27",
    "@angular/forms": "~8.2.1",
    "@angular/material": "~8.2.1",
    "@angular/platform-browser": "~8.2.1",
    "@angular/platform-browser-dynamic": "~8.2.1",
    "@angular/platform-server": "~8.2.1",
    "@angular/pwa": "~0.802.1",
    "@angular/router": "~8.2.1",
    "@angular/service-worker": "~8.2.1",
    "@progress/kendo-angular-buttons": "~5.0.0",
    "@progress/kendo-angular-charts": "~4.0.1",
    "@progress/kendo-angular-common": "~1.1.0",
    "@progress/kendo-angular-dateinputs": "~4.0.1",
    "@progress/kendo-angular-dropdowns": "~4.0.0",
    "@progress/kendo-angular-excel-export": "~3.0.1",
    "@progress/kendo-angular-grid": "~4.1.1",
    "@progress/kendo-angular-inputs": "~6.1.1",
    "@progress/kendo-angular-intl": "~2.0.0",
    "@progress/kendo-angular-l10n": "~2.0.0",
    "@progress/kendo-angular-menu": "~2.0.0",
    "@progress/kendo-angular-popup": "~3.0.1",
    "@progress/kendo-angular-scrollview": "~3.0.0",
    "@progress/kendo-angular-tooltip": "~2.1.0",
    "@progress/kendo-angular-treeview": "~4.0.1",
    "@progress/kendo-angular-pdf-export": "~2.0.0",
    "@progress/kendo-data-query": "~1.5.1",
    "@progress/kendo-drawing": "~1.5.12",
    "@progress/kendo-theme-default": "~4.1.0",
    "@progress/kendo-theme-material": "~3.2.0",
    "classlist.js": "^1.1.20150312",
    "file-saver": "^2.0.1",
    "hammerjs": "^2.0.8",
    "jsqr": "^1.0.4",
    "localforage": "^1.5.6",
    "material-design-icons": "^3.0.1",
    "normalize.css": "^7.0.0",
    "node-sass": "~4.12.0",
    "roboto-fontface": "^0.10.0",
    "rxjs": "~6.5.3",
    "rxjs-compat": "~6.3.3",
    "tslib": "^1.9.0",
    "web-animations-js": "^2.3.1",
    "zone.js": "^0.9.1"
  },
  "devDependencies": {
    "@angular-devkit/build-angular": "~0.803.4",
    "@angular-devkit/build-ng-packagr": "~0.803.4",
    "@angular-builders/jest": "~8.2.0",
    "@angular/cli": "~8.3.4",
    "@angular/compiler-cli": "~8.2.1",
    "@angular/language-service": "~8.2.1",
    "@compodoc/compodoc": "~1.1.10",
    "@types/express": "~4.17.1",
    "@types/hammerjs": "^2.0.36",
    "@types/jest": "~24.0.18",
    "@types/node": "12.7.5",
    "codelyzer": "^4.5.0",
    "jasmine-core": "~3.3.0",
    "jasmine-spec-reporter": "~4.2.1",
    "karma": "~4.1.0",
    "karma-chrome-launcher": "~2.2.0",
    "karma-coverage-istanbul-reporter": "~2.0.1",
    "karma-jasmine": "~2.0.1",
    "karma-jasmine-html-reporter": "^1.4.0",
    "protractor": "~5.4.1",
    "ts-node": "~7.0.1",
    "tslint": "~5.11.0",
    "tslint-config-prettier": "~1.18.0",
    "typescript": "~3.5.3"
  }
}

यह मेरा कोणीय है।जेसन। क्या मेरी स्कीमा में कुछ गड़बड़ है?

0
Silvester Schn. 31 मार्च 2020, 15:21

1 उत्तर

सबसे बढ़िया उत्तर

अपनी angular.json फ़ाइल जांचें

हो सकता है कि बिल्ड कॉन्फ़िगरेशन में tsconfig.json पथ अनुपलब्ध हो

          "builder": "@angular-devkit/build-angular:browser",
          "options": {
            "outputPath": "dist/...",
            "index": "projects/.../src/index.html",
            "main": "projects/.../src/main.ts",
            "polyfills": "projects/.../src/polyfills.ts",
            "tsConfig": "projects/.../tsconfig.app.json",
...
1
C. Eggart 1 अप्रैल 2020, 14:27