मैं 2 पैकेज स्थापित कर रहा हूं: rxdart और flutter_plugin_pdf_viewer

rxdart: ^0.23.1
flutter_plugin_pdf_viewer: ^1.0.7

लेकिन flutter_plugin_pdf_viewer >=1.0.4 निषिद्ध है।

और यह त्रुटि संदेश है:

Because flutter_plugin_pdf_viewer >=1.0.4 depends on rxdart ^0.21.0 and flutterattendancesystem depends on rxdart ^0.23.1, flutter_plugin_pdf_viewer >=1.0.4 is forbidden.

So, because flutterattendancesystem depends on flutter_plugin_pdf_viewer ^1.0.7, version solving failed.
pub upgrade failed (1; So, because flutterattendancesystem dep
ends on flutter_plugin_pdf_viewer ^1.0.7, version solving failed.)
2
Allviss 26 मार्च 2020, 16:24

1 उत्तर

सबसे बढ़िया उत्तर

इस थ्रेड को देखें https://github.com/CrossPT/flutter_plugin_pdf_viewer/issues/59

इस रेपो का रखरखाव ठीक से नहीं किया जाता है, आप पीडीएफ दर्शक के लिए एक अलग पैकेज का उपयोग कर सकते हैं।

या अस्थायी सुधार के लिए निम्न कार्य करें

.pub-cache में flutter_plugin_pdf_viewer-1.0.7 फ़ोल्डर में pubspec.yaml को मैन्युअल रूप से संपादित करें और rxdart: ^0.21.0 को rxdart: ^0.23.1 पर सेट करें।

flutter_plugin_pdf_viewer-1.07/lib/src/document.dart में लाइन नंबर: 89 पर, Observable को बदलकर Stream कर दिया गया।

1
Alex Sunder Singh 26 मार्च 2020, 13:38