मुझे वास्तव में इस प्रश्न का उत्तर पहले ही मिल गया है, और मैं बस अपनी खोज का दस्तावेजीकरण करना चाहता हूं।

सबसे पहले, यह समस्या विंडोज पाउचडीबी के लिए लेवलडाउन मॉड्यूल के निर्माण के लिए विशिष्ट नहीं है। मैंने जो ऑनलाइन पढ़ा है, उससे यह काफी आम समस्या है।

इसका संबंध इस तथ्य से है कि nw-gyp किसी तरह nw-gyp configure और nw-gyp build command के बीच NW के लक्षित संस्करण को भूल गया। जब ऐसा होता है, तो एक TyperError: अमान्य संस्करण: अपरिभाषित फेंक दिया जाएगा।

-1
toyssamurai 19 जुलाई 2020, 06:50

1 उत्तर

सबसे बढ़िया उत्तर

समाधान वास्तव में बहुत सरल है, आपको केवल --target= को फिर से सेट करना है जब आप nw-gyp build करते हैं, जैसे:

nw-gyp configure --target=0.47.0
nw-gyp build --target=0.47.0
1
toyssamurai 19 जुलाई 2020, 03:50