मैं स्विफ्ट का उपयोग करके एक्सकोड 11.3.1 पर एक आईओएस ऐप बना रहा हूं और जानना चाहता हूं कि कौन से आईफोन मॉडल ऐप के अनुकूल होंगे। सिम्युलेटर Iphone 8 और इसके बाद के संस्करण दिखाता है। क्या इसका मतलब यह है कि कम आईफोन इसे नहीं चला पाएंगे?

मुझे कोई अच्छी व्याख्या या लिंक नहीं मिल रहा है।

-1
codedev 16 अप्रैल 2020, 06:24

1 उत्तर

सबसे बढ़िया उत्तर

Xcode संस्करण पुराने iPhones और उनके OS को सपोर्ट करने की कुंजी नहीं है।

इसके बजाय, अपने परिनियोजन लक्ष्य को देखें। आप जितना कम चुनेंगे, आपको उतने ही 'पुराने' iPhone मिलेंगे। उदाहरण के लिए, यदि आप अपने परिनियोजन लक्ष्य के रूप में iOS 8 चुनते हैं, तो आपका ऐप पुराने उपकरणों का समर्थन करेगा जो iOS 8 का उपयोग कर सकते हैं लेकिन 13 का नहीं।

सिम्युलेटर केवल उन उपकरणों की एक सूची दिखाता है जो एक्सकोड के वर्तमान संस्करण द्वारा समर्थित नवीनतम आईओएस संस्करण का समर्थन करते हैं, लेकिन इसका मतलब यह नहीं हो सकता है कि यह उन तक ही सीमित है।

ध्यान दें कि पुराने उपकरणों के लिए नए एपीआई का उपयोग किया जाता है, हालांकि आप इसे अभी भी ऐसा बना सकते हैं कि यह नए उपकरणों के लिए काम करेगा, पुराने उपकरणों के लिए कुछ पुराने एपीआई में फॉलबैक के साथ।

0
vincent 16 अप्रैल 2020, 03:32