रेल पर रूबी का उपयोग करने का यह मेरा पहला अवसर है मैंने इस लिंक से रेल स्थापित की हैं http://railsinstaller.org/en मैंने अपना पहला प्रोजेक्ट बनाया लेकिन रेल सर्वर चलाने की कोशिश करते समय मुझे परेशानी का सामना करना पड़ रहा है, सबसे पहले, इसे चलाने की आवश्यकता है

 bundle install

bundle install चलाने के बाद मुझे कमांड लाइन में कई मुद्दे दिखाई देते हैं

To see why this extension failed to compile, please check the mkmf.log which can
be found here:

C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.2/mkmf.log

extconf failed, exit code 1

Gem files will remain installed in
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/gems/sqlite3-1.4.2 for
inspection.
Results logged to
C:/RailsInstaller/Ruby2.3.3/lib/ruby/gems/2.3.0/extensions/x86-mingw32/2.3.0/sqlite3-1.4.2/gem_make.out

An error occurred while installing sqlite3 (1.4.2), and Bundler cannot continue.
Make sure that `gem install sqlite3 -v '1.4.2' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  sqlite3 

तो मैं इन दलीलों को कैसे ठीक कर सकता हूं?

0
Kareem Sultan 27 सितंबर 2020, 17:59

1 उत्तर

सबसे बढ़िया उत्तर

अपने Gemfile में आपके द्वारा उपयोग किए जा रहे sqlite के संस्करण को कम करने का प्रयास करें।

gem 'sqlite3', '~>1.3.13'

देख रहे हैं https://rubygems.org/gems/sqlite3/versions/ 1.3.13-x86-mingw23, 1.3.13 mingw23 के साथ नवीनतम समर्थित संस्करण प्रतीत होता है।

0
Pedro Caseiro 27 सितंबर 2020, 15:05