मुझे निम्नलिखित समस्या मिली। एनाकोंडा को अपडेट करने के बाद क्योंकि मुझे ज्यूपिटर नोटबुक में एक प्रोजेक्ट में skimage.io आयात करने में त्रुटि मिली है, इससे भी बड़ी त्रुटि दिखाई देती है - डेड कर्नेल। अभी मैं कभी भी एक परियोजना शुरू नहीं कर सका क्योंकि जुपिटर निम्नलिखित त्रुटि देता है:

Copy/paste this URL into your browser when you connect for the first time,
to login with a token:
    http://localhost:8888/? 
token=aaf85a5e18489792c87cce65d7a53a0263cd5c08cc7248b 6
[I 00:55:13.451 NotebookApp] Accepting one-time-token-authenticated 
connection from ::1
[I 00:55:31.607 NotebookApp] Kernel started: 608d2190-59e6-4888-b09a- 
e616f67bd5b4
Traceback (most recent call last):
ERROR:tornado.general:Uncaught exception in ZMQStream callback
Traceback (most recent call last):
File "C:\Program Files\Anaconda3\lib\site- 
packages\zmq\eventloop\zmqstream.py", line 432, in _run_callback
callback(*args, **kwargs)
File "C:\Program Files\Anaconda3\lib\site- 
packages\tornado\stack_context.py", line 276, in null_wrapper
return fn(*args, **kwargs)
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 283, in dispatcher
return self.dispatch_shell(stream, msg)
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 233, in dispatch_shell
self.pre_handler_hook()
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 248, in pre_handler_hook
self.saved_sigint_handler = signal(SIGINT, default_int_handler)
File "C:\Program Files\Anaconda3\lib\signal.py", line 47, in signal
handler = _signal.signal(_enum_to_int(signalnum), _enum_to_int(handler))
ValueError: signal only works in main thread  File "C:\Program 
Files\Anaconda3\lib\runpy.py", line 193, in _run_module_as_main
"__main__", mod_spec)

File "C:\Program Files\Anaconda3\lib\runpy.py", line 85, in _run_code
exec(code, run_globals)
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel_launcher.py", 
line 16, in <module>
app.launch_new_instance()
File "C:\Program Files\Anaconda3\lib\site- 
packages\traitlets\config\application.py", line 658, in launch_instance
app.start()
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelapp.py", 
line 477, in start
ioloop.IOLoop.instance().start()
File "C:\Program Files\Anaconda3\lib\site- 
packages\tornado\platform\asyncio.py", line 112, in start
self.asyncio_loop.run_forever()
ERROR:tornado.general:Uncaught exception in zmqstream callback
Traceback (most recent call last):
File "C:\Program Files\Anaconda3\lib\site- 
packages\zmq\eventloop\zmqstream.py", line 450, in _handle_events
self._handle_recv()
File "C:\Program Files\Anaconda3\lib\site- 
packages\zmq\eventloop\zmqstream.py", line 480, in _handle_recv
self._run_callback(callback, msg)
File "C:\Program Files\Anaconda3\lib\site- 
packages\zmq\eventloop\zmqstream.py", line 432, in _run_callback
callback(*args, **kwargs)
File "C:\Program Files\Anaconda3\lib\site- 
packages\tornado\stack_context.py", line 276, in null_wrapper
return fn(*args, **kwargs)
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 283, in dispatcher
return self.dispatch_shell(stream, msg)
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 233, in dispatch_shell
self.pre_handler_hook()
File "C:\Program Files\Anaconda3\lib\site-packages\ipykernel\kernelbase.py", 
line 248, in pre_handler_hook
self.saved_sigint_handler = signal(SIGINT, default_int_handler)
File "C:\Program Files\Anaconda3\lib\signal.py", line 47, in signal
handler = _signal.signal(_enum_to_int(signalnum), _enum_to_int(handler))
ValueError: signal only works in main thread  File "C:\Program   
Files\Anaconda3\lib\asyncio\base_events.py", line 409, in run_forever
1
default_settings 2 अप्रैल 2018, 01:12

8 जवाब

सबसे बढ़िया उत्तर

बहुत सारे "त्वरित सुधार" की कोशिश करने के बाद - ज्यूपिटर पैकेज और आदि को अनइंस्टॉल और इंस्टॉल करें, शुरुआत से ही एनाकोंडा को अनइंस्टॉल और इंस्टॉल करने का एकमात्र तरीका था। यदि आप खरोंच से सभी पैकेजों को स्थापित करने से डरते नहीं हैं (मेरे मामले में यह आवश्यक नहीं था) तो यह समाधान सबसे अच्छा है।

1
default_settings 3 अप्रैल 2018, 18:11

मुझे भी समस्या का सामना करना पड़ा जब l अपने ज्यूपिटर लैब का उपयोग कर रहा था, l ने कमांड के साथ संस्करण को अपग्रेड किया।
pip install jupyterlab —upgrade
सिस्टम वाइड इंस्टालेशन से बचने के लिए
pip install jupyterlab —upgrade —user

0
Simbarashe Timothy Motsi 15 अगस्त 2018, 01:09

मुझे लगता है कि यहाँ समस्या बवंडर संस्करण बेमेल के कारण है। समस्या को हल करने के लिए आपको बस बवंडर के पुराने संस्करण में डाउनग्रेड करना चाहिए। कम से कम, यही मेरे लिए काम किया। यह काम कर जाना चाहिए।

conda install tornado=4.5.3 
1
ROHIT GHOSH 18 मई 2018, 09:00

conda के साथ ज्यूपिटर नोटबुक (संस्करण 5.6) की बिल्कुल नई स्थापना के लिए निम्नलिखित पैकेजों की आवश्यकता है, इसलिए tornado का कार्यशील संस्करण 5.1 है।

ipykernel:          4.8.2-py36_0       conda-forge
ipywidgets:         7.4.0-py_0         conda-forge
jupyter:            1.0.0-py_1         conda-forge
jupyter_client:     5.2.3-py_1         conda-forge
jupyter_console:    5.2.0-py36_0       conda-forge
nbconvert:          5.3.1-py_1         conda-forge
notebook:           5.6.0-py36_0       conda-forge
qtconsole:          4.3.1-py36_0       conda-forge
terminado:          0.8.1-py36_0       conda-forge
tornado:            5.1-py36h470a237_1 conda-forge
widgetsnbextension: 3.4.0-py36_0       conda-forge

इस समस्या को ठीक करने के लिए, कोई व्यक्ति tornado के नवीनतम संस्करण को मैन्युअल रूप से स्थापित कर सकता है:

conda install tornado --update

या फिर से jupyter नोटबुक को फिर से स्थापित करें:

conda uninstall jupyter tornado
conda install jupyter
8
anothernode 9 अगस्त 2018, 14:11

Ipykernel को अपग्रेड करना मेरे लिए काम कर गया

conda upgrade ipykernel
2
Stephen Kennedy 27 सितंबर 2018, 13:00

विभिन्न समाधानों की कोशिश करने के बाद, विभिन्न निर्भरताओं का उन्नयन और गिरावट conda upgrade --all मेरे लिए काम किया।

0
ashish saxena 24 जिंदा 2020, 09:41

मेरे लिए, यह समस्या ipykernel संस्करण के गलत मिलान के साथ थी। मैंने google-colab इंस्टॉल किया था जिसने मेरी ipykernel को डाउनग्रेड कर दिया। google-colab को अनइंस्टॉल करने और ipykernel को नवीनतम में अपग्रेड करने के बाद समस्या हल हो गई।

pip uninstall google-colab

pip install --upgrade ipykernel

0
ak2205 17 पद 2020, 10:26

कोंडा अपग्रेड - मेरे लिए सभी काम करता है

0
paul xiong 17 मार्च 2020, 19:15