मेरे पास मूल रूप से एक पूरी तरह से खाली फ़ोल्डर है जिसमें एक फ़ाइल है, test.js। मैं कुछ मॉड्यूल स्थापित करना चाहता था, लेकिन जब मैं npm install express जैसा कुछ करने की कोशिश करता हूं तो मुझे एक त्रुटि मिलती है जो कहती है कि मेरे पास package.json फाइल नहीं है।

$ npm install express

> node-icu-charset-detector@0.1.3 install /Users/me/node_modules/node-icu-charset-detector
> node-gyp rebuild

  CXX(target) Release/obj.target/node-icu-charset-detector/node-icu-charset-detector.o
../node-icu-charset-detector.cpp:7:10: fatal error:
      'unicode/ucsdet.h' file not found
#include <unicode/ucsdet.h>
         ^
1 error generated.
make: *** [Release/obj.target/node-icu-charset-detector/node-icu-charset-detector.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:270:23)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Darwin 15.0.0
gyp ERR! command "/usr/local/Cellar/node/5.1.0/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /Users/me/node_modules/node-icu-charset-detector
gyp ERR! node -v v5.1.0
gyp ERR! node-gyp -v v3.0.3
gyp ERR! not ok
npm WARN install:node-icu-charset-detector@0.1.3 node-icu-charset-detector@0.1.3 install: `node-gyp rebuild`
npm WARN install:node-icu-charset-detector@0.1.3 Exit status 1
/Users/me
├── express@4.13.3
├── UNMET PEER DEPENDENCY react@>=0.14.0 <0.15.0
└── UNMET PEER DEPENDENCY react-dom@>=0.14.0 <0.15.0

npm WARN ENOENT ENOENT: no such file or directory, open '/Users/me/package.json'
npm WARN EPEERINVALID mongoskin@1.4.13 requires a peer of mongodb@~1.4 but none was installed.
npm WARN EPEERINVALID react-router-component@0.28.0 requires a peer of react@>=0.14.0 <0.15.0 but none was installed.
npm WARN EPEERINVALID react-router-component@0.28.0 requires a peer of react-dom@>=0.14.0 <0.15.0 but none was installed.
npm WARN EPEERINVALID react-tap-event-plugin@0.2.1 requires a peer of react@^0.14.0 but none was installed.
npm WARN EPACKAGEJSON me No description
npm WARN EPACKAGEJSON me No repository field.
npm WARN EPACKAGEJSON me No README data
npm WARN EPACKAGEJSON me No license field.
2
Saad 29 नवम्बर 2015, 14:17

3 जवाब

सबसे बढ़िया उत्तर

मूल रूप से npm install के तीन मुख्य रूप हैं:

  1. npm install: package.json पढ़ें, और इस निर्देशिका में सब कुछ स्थापित करें।
  2. npm install express: इस निर्देशिका में एक्सप्रेस स्थापित करें।
  3. npm install --save express: इस निर्देशिका में एक्सप्रेस स्थापित करें, और इसे पैकेज में सहेजें। json।

दूसरे फ़ॉर्म को यहां मौजूद होने के लिए package.json की आवश्यकता नहीं है:

$ npm install express
express@4.13.3 node_modules/express
├── escape-html@1.0.2
├── array-flatten@1.1.1
...

यदि आपको एक त्रुटि संदेश मिलता है, तो कुछ और गलत है।

1
Steve Bennett 29 नवम्बर 2015, 11:25

शीर्षासन करें: यदि आप scoped संकुल का उपयोग कर रहे हैं, तो स्कोप्ड संकुल मैं भयभीत हूँ।

0
cifuentes 23 सितंबर 2016, 13:58

नहीं, यह package.json के लिए आवश्यक नहीं है।

  1. आप इसमें विभिन्न मॉड्यूल नामों की संख्या रख सकते हैं जो मॉड्यूल हैं आप npm स्थापित के हिट पर स्थापित करना चाहते हैं।

  2. आप मॉड्यूल के संस्करणों पर बेहतर नियंत्रण रख सकते हैं

  3. आप निर्भरता और देव-निर्भरता जैसे मॉड्यूल को अलग कर सकते हैं

आपके लिए 'एनपीएम इंस्टॉल एक्सप्रेस' आपके लिए एक्सप्रेस मॉड्यूल स्थापित करेगा।

0
Dnyanesh 29 नवम्बर 2015, 11:42