यह समस्या ऐसी लग रही है जैसे इसका अभी तक कोई स्पष्ट समाधान नहीं है। मैंने SSH के माध्यम से वर्डप्रेस का एक साफ संस्करण स्थापित किया है जिसमें फ़ोल्डर की अनुमति 755 और फाइल की अनुमति 644 है।

मुझे चित्र, अद्यतित प्लगइन्स आदि अपलोड करने में कोई समस्या नहीं है, लेकिन जब किसी छवि को संपादित करने की बात आती है तो मुझे यह त्रुटि मिलती है:

enter image description here

WP_DEBUG कुछ नहीं दिखाता है, और वेबसाइट पर कोई अन्य त्रुटियां नहीं हैं।

3
Nick 1 पद 2015, 20:43

4 जवाब

सबसे बढ़िया उत्तर

यहाँ एक ही समस्या है, मैं php के साथ जीडी स्थापित करना भूल गया ... इसे स्थापित करें समस्या को ठीक करें:

sudo apt install php7.2-gd
3
M4rc3di4L 13 फरवरी 2019, 08:49

सबसे संभावित कारण स्थापित mod-gd नहीं है।

वर्डप्रेस छवियों को हेरफेर करने के लिए जीडी ग्राफिक लाइब्रेरी का उपयोग करता है (wp-admin/includes/image.php देखें), और यह त्रुटि तब दिखाई देती है जब यह स्थापित नहीं होती है।

यह कहीं न कहीं शुरू किए गए व्हाट्सएप के कारण भी हो सकता है। किसी भी php समापन टैग ?> की जाँच करें और उन्हें हटा दें। उनका उपयोग नहीं किया जाना चाहिए क्योंकि उनके बाद व्हॉट्सएप पेश किया जा सकता है।

3
Tristan 1 पद 2015, 17:57

यह मेरे साथ हुआ जब मैंने स्केलिंग के बाद छवि को पुनर्स्थापित करने की कोशिश की और अधिकतम आकार मूल छवि आकार से नीचे था। मैं अधिकतम आकार नहीं बदल सका, लेकिन मेरी छवि की प्रतिलिपि Google पर मिली और उसे बदल दिया गया।

0
Asaf M 10 अक्टूबर 2019, 11:26

यदि आप एक होस्टिंग कंपनी के साथ ऑनलाइन काम कर रहे हैं और आपके होस्टिंग प्लेटफॉर्म के रूप में cpanel है, तो आप
के माध्यम से Cpanel में इस मॉड्यूल को सक्षम कर सकते हैं PHP चयनकर्ता --- & gt; एक्सटेंशन --- & gt; जी.डी.

देखिए तस्वीरें बोले

Cpanel (PHP चयनकर्ता)

एक्सटेंशन - & gt; गोलों का अंतर

-1
Antonis Mihail 13 अक्टूबर 2020, 14:00